Erleben, was verbindet. Erleben, was verbindet.

21.10.2021 - einige veraltete sFTP Clients funktionieren nicht mehr


Seit einigen Tagen klappt der Zugang mit einigen veralteten sFTP Clients nicht mehr, obwohl an den Einstellungen nichts geändert wurde.

Das tritt nur mit Programmen auf, die intern auf eine veraltete OpenSSH Version aufsetzen. Wir konnten den Fehler vor allem bei veralteten Webseitenerstellungsprogrammen mit eingebauten sFTP Client feststellen.

Installieren Sie eine aktuelle Version Ihrer Software. Bei Programmen, die vom Hersteller nicht mehr gepflegt werden, kann die lokale Publizierung in Verbindung mit dem WebDAV Zugang eine Option sein.

Hintergrundinformationen:

Am 06.10.2021 wurde unser sFTP Server auf die OpenSSH-Version 8.8 aktualisiert. Mit diesem Update ist die Unterstützung für RSA-SHA1 weggefallen. Dieser Algorithmus ist schon seit vielen Jahren veraltet und es werden in OpenSSH auch schon seit vielen Jahren Alternativen dazu angeboten.

Die Problematik tritt daher nur bei Software auf, die intern eine OpenSSH Version verwendet, die mehr als 5 Jahren nicht vom Hersteller aktualisiert wurde.